VoodooPad 5 installation on second computer

Christin's Avatar

Christin

07 Jul, 2020 11:56 AM

Hi!
I tried contacting support via mail, but have as of yet received no answer. But I can see that this forum is quite active, so I was hoping for some help here!

In mid 2018 I downloaded a registration key for VoodooPad, and installed it on an iMac late 2013. Everything went smoothly, entering registration, and I currently run the latest VoodooPad version, 5.3.0. on macOS High Sierra. I haven't really begun using the program much yet, but everything seems to be running fine to me.

Then, I recently acquired a Macbook Pro late 2013, with macOS Mojave. I downloaded the VoodooPad zip, and upon opening it, the whole thing acts weird. It lets me enter the registration key, and this "thank you" box comes up. But I don't get any box where I'm supposed to move the VoodooPad program to the Application folder. And VoodooPad doesn't install itself into the Launchpad. It isn't even in the Recent folder. But, it is in the Downloads folder. And upon launching it from there, it does seem to work, VoodooPad shows up as active in the Doc (with the dot underneath it). The menu shows up, and I can open a new document fine. But when I close the computer down and re-start it, VoodooPad is no longer on the Doc, even though I've asked the computer to open things as are, and so VoodooPad has just disappeared on its own. And the only way I can find and re-launch it is through Downloads folder...

Not sure whether I want to throw a bunch of wiki in there, when it seems that the program isn't fully installed?

Oh, I did try to Trash it and empty Trash, and re-download and install it. Same thing happened over and over again when I tried that, and I'm not sure that I Trashed it properly though, since every time I re-downloaded it, the Registration Key was already pre-filled and the "new" VoodooPad also remembered and contained a test document I wrote on the VoodooPad that I Trashed. I confess that I'm no Mac Wiz and maybe I didn't uninstall the faulty (?) VoodooPad properly?

THANKS A BUNCH for any help with this! I want my VoodooPad in the Launchpad, fully working, this is my aim! (And, can I trust in the "weird" VoodooPad that I currently have? (It looks fine, save for these weird things with launching it, and it un-launching on its own when the computer is off.)

Kindly, Christin

  1. 1 Posted by Paul on 08 Jul, 2020 04:12 PM

    Paul's Avatar

    When VoodooPad is open, right click on the dock icon, select Options, then Keep in Dock

  2. 2 Posted by Christin on 08 Jul, 2020 08:18 PM

    Christin's Avatar

    Thanks a bunch, Paul! It works beautifully, and I learned a bit more about the Mac!

    VoodooPad now stays in the Doc, and things feel a bit more stable. Created a few testdocuments and tried saving them, and they're also there properly saved in their chosen locations, shows up in Documents folder as should, and can open them from there, even after I close down and re-start the computer.

    So, it definitely seems that the VoodooPad documents are saved on the computer as they should, and now I can access VoodooPad from the Doc, which is very convenient and accessible to me.

    So, thank you so much again! I appreciate your time, and the very useful reply!

    ----------

    Still, something seems weird, because these documents and activities DOESN´T show up in the Recents folder. Maybe they aren't supposed to, but all my Scapple and Scrivener and all other opened pdfs and other stuff documents do, as my Mac keeps track of me and all of my activities, as always! (and these Recents show-ups ARE saved to the same locations as the VoodooPad test document No-Shows and all that, which also shouldn't matter?)

    So, VoodooPad shows up in the Downloads folder, and its documents saves to Documents folder when I choose that, and VoodooPad stays glued to Docs now, thanks to above help. These things seem stable enough, now.

    But it seems that VoodooPad itself suffers short-term memory loss or something, that it doesn't show up in Recents? Or, its like it isn't established properly on the computer, its as if, to the Mac, I didn't use the program at all, even though I just did! (I tried re-starting the computer, and it still doesn't show up in Recents)

    AND, it doesn't show up in Applications folder either, and I´d love for VoodooPad to be also found in the Launchpad...

    Actually, its as if, to the Mac, the program isn't really installed, and because it isn't installed the Mac isn't registering my activity within the program, new documents created and stuff... But despite this the Mac saves them in Documents when asked to?

    I honestly don't know enough about computers and about programs to understand this, but its intriguing enough!

    I guess for me the bottom line is:

    Should I worry about these oddities now, or just get on with filling the VoodooPad with wiki and trust the stability of it, because in truth I can live with the personality quirks of this copy I downloaded, now that its easily accessible on Doc for me, and saves the documents where I ask it to... The ghost documents that, according to Recents, never existed. And where VoodooPad, according to Applications, are not on this computer...

    Maybe its a stealth mode? As said, I can live with it, but can I trust it?

    Kindly, Christin

  3. 3 Posted by Paul on 10 Jul, 2020 12:24 AM

    Paul's Avatar

    Christin:

    Right clicking the VP icon in the dock is your friend for several things.

    If you select Show In Finder, perhaps you can discover why the app is not in the /Applications folder with all your other normal applications (not the local ~/Applications folder).

    You should also see a list of journals you have opened with VP when right clicking on the dock icon. I don't have an explanation for why you don't see recent files.

  4. 4 Posted by Christin on 10 Jul, 2020 09:26 AM

    Christin's Avatar

    Dear Paul,

    Thank you again! It will be so much easier to launch documents and a whole bunch of other stuff, now that I have the knowledge that I can right click on all of the icons in the Doc! That's tremendously useful bit of news to me!

    Well, I don't know enough to understand the distinction you make between Applications folder and local Applications folder? (All of the folders I've been referring to in my previous posts, have been from launching Finder icon in the Doc.)

    But, when I right click the VoodooPad icon in Doc, and select Show In Finder, it opens up the Finder Downloads folder, where VoodooPad is located. It does not indicate, either, that VoodooPad resides anywhere else in Finder. Just Downloads folder.

    So, I tried highlighting the VoodooPad file there, and click on the gear icon of Downloads folder:

    Show Package Contents option, proved too advanced for me. (Its got a Contents folder, and in it are 7 other folders, plus two documents with info in the name. The 7 folders contain frameworks, xpcservices, library, resources, plugins, macOS, and code signature.)

    The other option that seemed like it could be useful (in the gear icon menu), was the Get Info one. So, I clicked that, and it basically confirms that VoodooPads location (Where) is in the Downloads folder on this Mac. In a way, it might be useful to know that. It simply looks like any other program, residing somewhere on the computer, with a proper pathway to the folder where it can be found... Except of course, I don't want it installed in the Downloads folder. (And, is it really fully installed, I can´t tell.)

    But, it does match the experience I had on trying to install VoodooPad, since it just started running right away, and there was no box where I could drag and drop it to Applications, or anything. It just launched, with no saving it anywhere. (In the instalment process, there was never any step where I got to chose its location.)

    (And, VP documents, of course, still aren´t in Recents Folder, checked again today.)

    So; in short, I haven't been able to discover why VoodooPad is this way.

    (On my other computer, with the same registration key, VoodooPad shows up in the LaunchPad, and acts like all the other programs there. And instalment process, to my recollection, was perfectly normal, with drag and drop to Applications folder etc... So, something definitely seems missing here, in comparance.)

    Has anyone else has this experience, or is it more of a unique incident?

    ----------------------

    Paul: Its ok that you can't help me further! Your eye-opening on-point comments have been very helpful, not just for the VoodooPad program, but for Mac life in general. Very kind of you, and I appreciate that. :-)

    There's strength in numbers, and maybe someone else has a solution or part of a solution to these things...

    Maybe someone else can chime in, and know what's up with the VoodooPad installation?

    Anyway, I appreciate the existence of this forum!

    Kindly, Christin

  5. 5 Posted by Paul on 10 Jul, 2020 03:09 PM

    Paul's Avatar

    Christin:

    Drag VP from the Downloads folder to the Applications folder. Think of the Downloads folder as a temporary folder. I do not include it in my backups, for example.

  6. 6 Posted by Christin on 12 Jul, 2020 10:39 AM

    Christin's Avatar

    Dear Paul,

    It worked!

    Long story short: Everything looks perfectly healthy and fine now!

    And, test document shows up in Recents folder!

    (I wrote a longer reply on this, but it doesn't seem to have uploaded to the forum.)

    Thank you SO MUCH for the sharing of your time and knowledge. Thank you for having helped me solve this! I just want you to know its very appreciated, and things work like a charm now!

    Kindly, Christin

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac