Links not working on VoodooPad IOS version.

mandy's Avatar

mandy

23 Apr, 2018 03:55 AM

It seems my links in my VoodooPad documents no longer work on IOS. I have the latest version (11.3) of IOS. The links work find on my mac version of VoodooPad. I purchased the app from the app store, and have the latest version from there. I tried restarting. I also deleted and re-installed the app. When I click a link, it simply puts the document in edit mode rather than opening the page the link goes to. What can be the problem? I created a new document on my iOS device (iPhone 8), and made a link to a new page. It still doesn't go to the new page, but is does sync with my dropbox and works fine on the mac version. I look forward to hearing from you! ~Mandy

  1. 1 Posted by rick on 23 Apr, 2018 05:07 AM

    rick's Avatar

    I'm also having this problem. It seems that if I press and hold on a link for a second, though, it highlights it oddly, and then when I release it takes me to the link. But that means navigating through a document requires a 1-second press on each link, which is extremely annoying. How is this intended to work?

  2. 2 Posted by Paul on 23 Apr, 2018 01:56 PM

    Paul's Avatar

    Yeah, I'm also seeing this on all my iOS devices, across all my documents: single-word links open with a long press, links with any spaces do nothing. Kind of destroys the functionality on my iDevices until a fix is in, unfortunately. (And I was REALLY looking forward to getting back to using VP as my main resource!)

  3. Support Staff 3 Posted by Sarah on 23 Apr, 2018 04:20 PM

    Sarah's Avatar

    Hi Mandy,

    Thanks for posting this, and I apologize for any trouble this has caused. There seems to be an issue with links that have spaces in them not working on the iOS version of VoodooPad 5.2.0. Currently, links that have single words should work using long-press. Do you experience the same issue with single-word links after using long-press?

    Thank you Rick and Paul for your feedback as well. We will look into this issue as soon as possible, and I've passed your concerns along to the team. Please let me know if you have any further concerns or questions.

    All the best,

    Sarah
    Primate Labs Inc.

  4. 4 Posted by mandy on 23 Apr, 2018 04:55 PM

    mandy's Avatar

    Just tried the long-press, and it works. Thanks for pointing this out! I can get by with this until there is a fix. Any idea when a fix will come? I run my life out of VoodooPad! lol

  5. 5 Posted by rick on 24 Apr, 2018 04:52 AM

    rick's Avatar

    For an app that is basically all about clicking on links, why did the devs decide to make that require a long press? This has been one of my favorite apps for years and I use it daily, but I'm finding it really hard to use on iOS now.

  6. Support Staff 6 Posted by Sarah on 24 Apr, 2018 03:15 PM

    Sarah's Avatar

    Hi Rick,

    In VoodooPad 5.2.0, you no longer need to click edit each time you need to edit the text. As a result, long-press has been integrated as the new way to click links on iOS. This keeps the user from accidentally clicking links when editing.

    We appreciate your feedback on this new feature and we will see if we can incorporate it into future updates.

    All the best,

    Sarah
    Primate Labs Inc.

  7. 7 Posted by mandy on 24 Apr, 2018 05:08 PM

    mandy's Avatar

    Ummm...so this isn't a bug, it's a feature. I think it would have made more sense for the long press to cause it to go into edit mode, and the the light press to follow the link. Regardless, you might want to include something in the user interface that lets the user know about the change. Maybe a pop up tutorial that plays automatically after install that could be found in the settings for later views.

    Now that the app has already been sent to users, could we request a setting that swaps the way long press and click to edit work?

  8. Support Staff 8 Posted by Sarah on 24 Apr, 2018 08:21 PM

    Sarah's Avatar

    Hi Mandy,

    I've taken note of your suggestions above and passed them on to the team. Thanks for the feedback.

    All the best,

    Sarah
    Primate Labs Inc.

  9. 9 Posted by Kent Sandvik on 24 Apr, 2018 11:41 PM

    Kent Sandvik's Avatar

    Hmm, interesting, with my Voodoopad documents on iOS long press (with multi word links) ends up in editing mode. Wasn't that the bug? Just now 99% of my links can't be opened.

  10. 10 Posted by mandy on 25 Apr, 2018 12:54 PM

    mandy's Avatar

    Sarah, exactly what is considered a bug versus a permanent change that we need to adapt to? For example, does Ken need to edit all his multi word links to single words, or will this be fixed in the future?

  11. Support Staff 11 Posted by Sarah on 25 Apr, 2018 03:19 PM

    Sarah's Avatar

    Hi Mandy,

    The multi-links not working is considered a bug because that isn't how it was intended to work. The long-press for links in general was a change for iOS. And this change is intended to work for all links (multi-word and single-word). We are working to fix this issue for the next update.

    I appreciate your patience. Let me know if you have any other questions.

    Warm regards,

    Sarah
    Primate Labs Inc.

  12. 12 Posted by rick on 13 May, 2018 12:56 AM

    rick's Avatar

    I've been trying to adapt to this change, but I continue to find that it has crippled VoodooPad's usability for me. Not only does it take far longer to navigate through my documents than it used to because I have to stop and hold for each link, it also is way too easy to accidentally enter edit mode when trying to click on a link. Then, once I've done that, I have to go click "done" and try again.

    Just now I accidentally did that 3 times in a row on the same link. Once I didn't hold long enough or my finger slipped; another couple times my finger was slightly off from the link and it brought select mode up again, which puts it into edit mode.

    I'm really upset about an app I use on iOS daily becoming so hard for me to use. Can you please let us know if the devs intend to address this? At the very least can they add a preference to invert the behavior? But I don't understand why we have this behavior at all... why not have a press *literally anywhere else in the document* go to edit mode, and a regular press on a link open the link?

  13. Support Staff 13 Posted by John on 13 May, 2018 03:39 AM

    John's Avatar

    So, yeah, this change wasn't our finest hour.

    When we removed the distinction between viewing and editing pages, we relied on the built-in "tap and hold" in iOS to open links. This is clumsy, especially for folks who do more reading than writing in VoodooPad for iOS. We're looking into ways to improve the experience and will hopefully have a solution in place in the next update.

    I appreciate everyone's patience when we screw up like this. We're getting a handle on VoodooPad, but I expect we'll make more mistakes as we continue to figure things out.

  14. 14 Posted by rick on 13 May, 2018 04:39 AM

    rick's Avatar

    Thank you very much for the speedy reply, John. I completely understand a few hiccups when making the first major update; I'm really glad you're planning to fix this!

  15. 15 Posted by Gengorou on 14 May, 2018 09:50 PM

    Gengorou's Avatar

    I'm using VoodooPad in Japanese. The long-press do not work even in single word links.

  16. 16 Posted by Kent Sandvik on 14 May, 2018 09:59 PM

    Kent Sandvik's Avatar

    Would it make sense to double-tap on anything but a word and it goes to edit mode, otherwise if tap or double tape on linked words (single/multiple word links) it opens the link?

    It would be nice to have this fixed soon, all of my VoodooPad documents on my iPhone/iPad are broken just now as I can't follow links.

  17. Support Staff 17 Posted by Sarah on 14 May, 2018 10:09 PM

    Sarah's Avatar

    Kent, thank you for that suggestion. I'll pass that along to the team. We appreciate your patience as we sort this out.

    Gengorou, thanks for posting. We are taking that issue into account and working to fix it for the next update.

    Warmly,

    Sarah
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac