Can I set a preferred pages text style?

richard's Avatar

richard

20 Apr, 2018 10:30 PM

I upgraded yesterday to version 5.2 and learning to use it. I cannot find any way that I can set a preferred font and size for the pages that come up when establishing a link. They are always Helvetica. I did see I can create a text style and apply it but seems an unnecessary step. Is there a way?

Thanks,
— Richard

  1. 1 Posted by Peter Hynes on 21 Apr, 2018 06:40 PM

    Peter Hynes's Avatar

    You can create a custom new file template called VPNewPageTemplate that will apply your preferred fonts, font sizes, and margins to any newly created link or page. Detailed instructions are in the documentation: https://www.voodoopad.com/documentation/customization/

    This is actually one of my favourite features in VoodooPad.

  2. Support Staff 2 Posted by Sarah on 23 Apr, 2018 07:03 PM

    Sarah's Avatar

    Hi Richard,

    Thanks for posting. To set a preferred font and size for your VoodooPad pages, go to VoodooPad > Preferences. In the General section you can change the font and size by clicking "Use the Font Panel to change text style". Another small window will pop up with the options to change the default style of text for rich text pages. Once you have set your new font preferences, the New Page Text box will show you a preview of what you will see on each new page that you create.

    If you follow the link that Peter posted, you will see some example screenshots. If you have any further questions, feel free to ask.

    All the best,

    Sarah
    Primate Labs Inc.

  3. 3 Posted by richard on 25 Apr, 2018 03:20 AM

    richard's Avatar

    Sarah,
    Thanks for the reply.
    I followed the link and was able to set up the formatting of the new pages to the font and size and color background that looks good. Only thing, right now, that I can’t figure out is that at the pages created by making a link — if i type in sentences and put a period at the end of the sentence it gets underlined as if misspelled. Can’t seem to fix that.
    Any suggestions?

    — Richard
    _______________________________

    “Love animals: God has given them the rudiments
    of thought and joy untroubled. Do not trouble their joy,
    don’t harass them, don’t deprive them of their happiness,
    don’t work against God’s intent.”
    ~ Fyodor Dostoevsky

  4. Support Staff 4 Posted by Sarah on 25 Apr, 2018 03:32 PM

    Sarah's Avatar

    Hi Richard,

    I'm having trouble reproducing the issue on my end. I'd like to gather some more information so I can take a closer look.

    What model of Mac and version of macOS are you currently using?

    Are you able to provide some screenshots of what you are experiencing?
    (e.g. what it looks like when you type the sentence and perhaps a screenshot of your preferences under the Editing section)

    Thanks,

    Sarah
    Primate Labs Inc.

  5. 5 Posted by richard on 25 Apr, 2018 06:35 PM

    richard's Avatar

    Sarah,
    I am using an iMac running Sierra, OS 10.12.6

    Here is a picture of one of the linked pages. Notice how each period has an underline.

    Here is my editing sheet. Notice I am using Lucida grande 14.

    _______________________________

    “Love animals: God has given them the rudiments
    of thought and joy untroubled. Do not trouble their joy,
    don’t harass them, don’t deprive them of their happiness,
    don’t work against God’s intent.”
    ~ Fyodor Dostoevsky

  6. 6 Posted by richard on 25 Apr, 2018 06:41 PM

    richard's Avatar

    Also Sarah, I followed instructions sent to me about setting up a default format for my linked pages, making a VPNewPageTemplate, but when I open a new document it does not carry over.

    Here is the way I have it set up.

    But here is how a new document looks. So not working right.

    _______________________________

    “Love animals: God has given them the rudiments
    of thought and joy untroubled. Do not trouble their joy,
    don’t harass them, don’t deprive them of their happiness,
    don’t work against God’s intent.”
    ~ Fyodor Dostoevsky

  7. Support Staff 7 Posted by Sarah on 25 Apr, 2018 10:07 PM

    Sarah's Avatar

    Hi Richard,

    Thanks for providing those screenshots. I was able to reproduce the way the periods look in your screenshot by creating a page with the name "."

    I'm not sure if that is the problem on your end, but I thought I would check anyway. Generally, if you type the name of a page that has been created, VoodooPad automatically turns it into a link to that page. Are you able to click the periods? When you go to your pages list, is there a page that is named with only a period?

    In regards to the VPNewPageTemplate issue you are experiencing, do you have that page in the Test document page list as well?

    Sarah
    Primate Labs Inc.

  8. 8 Posted by richard on 25 Apr, 2018 10:22 PM

    richard's Avatar

    Sarah,
    None of my link pages have a period in the name.

    If I click on a period a submenu says “email” or “open in address book.”

    _______________________________

    i created the VPNewPageTemplate as instructed in the help page I was sent to. When I created a new document it did not appear in the pages list. I assumed I was setting up a style for all documents I would create. Is it possible to do that? Or do I have to create the VPNewPageTemplate for each one? (awkward)

    — Richard
    _______________________________

    “Love animals: God has given them the rudiments
    of thought and joy untroubled. Do not trouble their joy,
    don’t harass them, don’t deprive them of their happiness,
    don’t work against God’s intent.”
    ~ Fyodor Dostoevsky

  9. Support Staff 9 Posted by Sarah on 26 Apr, 2018 05:30 PM

    Sarah's Avatar

    Hi Richard,

    Thanks for trying that. If you open the Contacts app on your Mac, do you by any chance have a contact listed with the name "."?

    In regards to the VPNewPageTemplate, you will need to copy that page for each new document that you create, in order to have the same formatting settings.

    (Note: If you use the instructions that I posted above (by going to Preferences, etc.), you should be able to set a preferred text and size for each new document. However, there is a known issue with background colours not carrying over to new documents. So your best bet may be to continue using the VPNewPageTemplate option until we are able to fix this issue.)

    Sarah
    Primate Labs Inc.

  10. 10 Posted by richard on 27 Apr, 2018 02:07 AM

    richard's Avatar

    See below.
    _______________________________

    “Love animals: God has given them the rudiments
    of thought and joy untroubled. Do not trouble their joy,
    don’t harass them, don’t deprive them of their happiness,
    don’t work against God’s intent.”
    ~ Fyodor Dostoevsky

  11. Support Staff 11 Posted by Sarah on 27 Apr, 2018 04:53 PM

    Sarah's Avatar

    Hi Richard,

    Did you mean to link to an attachment? If so, it did not show up here.

    Thanks,

    Sarah
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac