Can't open page by clicking link in iOS 5.2.0

zk.jiang's Avatar

zk.jiang

19 Apr, 2018 05:22 AM

Clicking link make the current page goes into Edit mode instead of taking me to the page that link points to

  1. 1 Posted by Marc on 19 Apr, 2018 11:53 AM

    Marc 's Avatar

    If you do a long hold, sometimes it opens the page. Very inconsistent for me though

  2. 2 Posted by Marc on 19 Apr, 2018 11:56 AM

    Marc 's Avatar

    Update: it seems like I can open the page with a long tap if the page is plain text

  3. Support Staff 3 Posted by Colin on 19 Apr, 2018 03:38 PM

    Colin's Avatar

    Hi,

    Thanks for reaching out to us about this, and I'm sorry for any confusion. You can follow page links on VoodooPad 5.2.0 for iOS by long-pressing the link.

    If you can't follow a link this way, please let me know what page type you're using, what the text of the link is, and what page type the link should direct you to.

    All the best,
    Colin
    Primate Labs Inc.

  4. 4 Posted by Marc on 19 Apr, 2018 03:48 PM

    Marc's Avatar

    Thanks Colin,

    The long tap works for me when opening a page that is formatted in plain text. this is consistent among different docs. but when clicking through to a page with an image, the long tap doesn't work. it highlights the words, i release, and then nothing.

    i can access the page by navigating directly to it. example word text (although it is consistent across my docs): "content activation"

    also, images render but are huge (doesn't scale to screen).

  5. 5 Posted by zk.jiang on 19 Apr, 2018 05:00 PM

    zk.jiang's Avatar

    Hi Colin,

    Long pressing works for my newly created doc, but not an existing one, home page in that doc has links to different types of doc, markdown or rich text. what's weird is, only one rich text page contains images can be opened. so it is entirely opposite behavior of what Marc is experiencing...

    Besides that, I want to say if this long pressing to open the page is by design, it is a not very intuitive design, and takes unnecessary extra time to open a page, I hope it is only a workaround for now.

  6. Support Staff 6 Posted by Colin on 19 Apr, 2018 05:31 PM

    Colin's Avatar

    I see, thank you both for following up with me, and I'm sorry for any trouble that you've encountered with the page link functionality. I'd like to ask a few additional questions to help us to narrow down the issues that you're experiencing.

    @zk.jiang, could you provide me an example or two of the text that your non-functional links have (i.e. the words that form the page link), as well as the text of the link that does work for you? Regarding the long press functionality, we implemented this as part of the redesign of the iOS page interface to allow editing without tapping the Edit button, to streamline the editing process. I'll pass your message along to my team and see if we can support following page links with a quicker gesture in a future update.

    @Marc, could you provide me with an example of the text that one of your working page links has (i.e. the words that form the page link) so that we can take a closer look at what could be causing this?

    Thanks for your patience and for any information you can provide as we investigate these issues.

    All the best,
    Colin
    Primate Labs Inc.

  7. 7 Posted by zk.jiang on 19 Apr, 2018 05:54 PM

    zk.jiang's Avatar

    Sure, I have sent my entire problematic doc to you([email blocked]). I am still just evaluating VoodooPad, so I don't have any serious data in my doc.

  8. Support Staff 8 Posted by Colin on 19 Apr, 2018 05:58 PM

    Colin's Avatar

    Hi zk.jiang,

    Thank you very much! I'll get back to you right away via email.

    All the best,
    Colin
    Primate Labs Inc.

  9. 9 Posted by Marc on 19 Apr, 2018 06:01 PM

    Marc's Avatar

    Colin, an example page link phrase is: "content activation"

  10. 10 Posted by Eugene on 19 Apr, 2018 09:45 PM

    Eugene's Avatar

    For me, tapping on any link on iOS doesn't work anymore and takes me into editing mode. I am using Markdown pages. Links are shown as blue, however other markdown styling, such as headings are no longer there.

    Please let me know if you need more help reproducing this issue.

    PS Thank you for the new versions!

  11. 11 Posted by zk.jiang on 19 Apr, 2018 09:47 PM

    zk.jiang's Avatar

    @Eugene

    According to Colin, what happened to me is when the link is composed of multiple words or when the link is composed of Chinese(I guess that applies to some charset too) text, this issue occurs.

  12. 12 Posted by Eugene on 19 Apr, 2018 09:50 PM

    Eugene's Avatar

    Update: long pressing seems to work right now on markdown pages.

  13. 13 Posted by Eugene on 20 Apr, 2018 04:36 PM

    Eugene's Avatar

    Update 2: zk.jiang is right. Long pressing links works on single-word links, but fails on multi-word links.

  14. 14 Posted by Marc on 20 Apr, 2018 05:34 PM

    Marc 's Avatar

    Yes that’s it for me too! (One word links work)

    Good detective work y’all

  15. 15 Posted by Fred on 21 Apr, 2018 12:30 AM

    Fred's Avatar

    I can't click to open link either. Long press works, as mentioned, only on one word links. Any link longer than one word doesn't work with long press for me.

    On Default Page Type I too have Rich Text, Plain Text, Plain Text as choices. No Markdown choice.

    Personally I would prefer if <Documents was on the bottom and Page Back was on the top of the screen. I guess it's something I have to get used to, but I keep exiting the document instead of returning to previous page. A home page button would be nice.

    Voodoo Pad iOS 5.2 version
    iOS 11.4 version iPad Pro 9.7

  16. Support Staff 16 Posted by Colin on 23 Apr, 2018 04:01 PM

    Colin's Avatar

    Hi Fred,

    Thanks for letting us know about these issues. I'll pass this information along to my team and let you all know as soon as I can if we can provide more information or any update to resolve this.

    There is currently an issue preventing multi-word page links from correctly redirecting to the linked page. We're investigating this issue, and will provide more information as soon as we can.

    All the best,
    Colin
    Primate Labs Inc.

  17. 17 Posted by colin198702 on 18 Jun, 2018 02:02 PM

    colin198702's Avatar

    Is there any update for this issue?

  18. 18 Posted by Blanchot on 21 Jun, 2018 12:46 PM

    Blanchot's Avatar

    Hi all,

    I'm also wondering if a fix for the 'two or more words = no working link' bug in the IOS version will arrive anytime soon.

    Two months ago Colin @PrimateLabs said: "We're investigating this issue, and will provide more information as soon as we can."

    I LOVE VoodooPad and have been using it on my desktop every day for more than 6 years now. Some years back I experimented with VoodooPad for iOS but quickly gave up on it (due to synching errors). Recently I re-installed it to use with some smaller files/projects and find it frustrating that multiple-word links are broken the way they are...

    Please let us know what's happening concerning this issue!

    Thanks, and thanks again for maintaining a truly GREAT piece of software!

    -- B.

  19. Support Staff 19 Posted by John on 21 Jun, 2018 02:40 PM

    John's Avatar

    I'm sorry for the delay in resolving this issue.

    Fixing this issue involved reworking how VoodooPad handles links internally (both on iOS and macOS). This took a while (especially as I broke a lot of functionality in the process). The good news is that we're almost ready to release an update. If the review process goes well we hope to have 5.2.1 in everyone's hands next week.

    In the meantime let me know if you have any other questions regarding this issue.

  20. 20 Posted by Kent Sandvik on 22 Jun, 2018 08:20 PM

    Kent Sandvik's Avatar

    Just tested the new iOS app and the multi-word links now work with my VoodooPad documents. Thanks.

  21. 21 Posted by zk.jiang on 23 Jun, 2018 04:40 AM

    zk.jiang's Avatar

    Yeah I can confirm new version works now (even when the link is composed of Chinese)

  22. 22 Posted by Blanchot on 23 Jun, 2018 10:26 AM

    Blanchot's Avatar

    Just saw the ios update is available and came here to check if others had tried it before installing it myself. :-)

    Thanks @John for the fix and Kent and zk.jiang for testing first! Will update now.

    UPDATE:
    Working perfectly so far! Thanks again Primate Labs!

  23. Support Staff 23 Posted by John on 23 Jun, 2018 02:56 PM

    John's Avatar

    Glad to hear it’s working for everyone! We’re getting slightly better at not breaking one thing when fixing another 🙂

  24. 24 Posted by Marc on 23 Jun, 2018 05:53 PM

    Marc 's Avatar

    Opening pages is much easier now, and works great.

    But I’m wondering if anyone else is experiencing what I am: I can open a page by tapping very far away from the actual page text. It seems like the tap zone is too big. I’m using left-aligned text, and I notice this when clicking to the right of the page I’m trying to open.

    The only issue with this is that when I tap to edit a page, it ends up opening the link to another page even though my finger was far away from the link text.

    I feel like I’m doing a horrible job explaining this. Hope you can make sense of it.

    Thanks for the updates!

  25. Support Staff 25 Posted by Sarah on 26 Jun, 2018 09:33 PM

    Sarah's Avatar

    Hi Marc,

    Thanks for bringing that up. I understand what you're saying. I've let the team know about this so we can take a look as soon as possible. If you have any other concerns, let us know.

    Sarah
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac