Geekbench on win7 laptop mousepad locks up

Christian's Avatar


01 Mar, 2013 09:22 AM

i've now tried downloading Geekbench a couple of times from varius vendors but every time i try opening the pogram my mousepad locks up/freezes and i have to do a hard shutdown (closing the pogram with alt-f4 does close the pogram but doesn't fix the mouse)
a have tried looking for an answere on the internet but no luck

my system is:
windows 7 64bit home premium
nvidia gtx670m (driving a 1600x900 screen)
laptop is a qosmio x870 from toshiba

Hope you can help me fix this problem


  1. Support Staff 1 Posted by John on 05 Mar, 2013 01:53 AM

    John's Avatar


    Thank you for your message, and I'm sorry for the delay in getting back to you.

    Could you download CPU-Z and let me know if it also locks up your laptop's mousepad?


  2. 2 Posted by Christian on 05 Mar, 2013 07:57 AM

    Christian's Avatar

    i've had cpu-z installed for ages, and this is the first i've seen of it freezing my mouse, but you are spot on, the program does the exact same thing.

    I have also found that connecting a wired mouse to the laptop, lets me move the mouse, but doesnt unfreeze the mousepad.


  3. Support Staff 3 Posted by John on 06 Mar, 2013 01:19 AM

    John's Avatar


    Geekbench uses the CPUID SDK (the same SDK that powers CPU-Z) to provide accurate system information. My guess is that part of the CPUID SDK is conflicting with the driver for your mousepad, causing it to lock up.

    I'll follow up with the CPUID SDK folks, and I'll look into getting you a build of Geekbench that doesn't use the CPUID SDK so you can benchmark your system.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac