Issues installing Geekbench 5 on a Chromebook

Brandon Dickerson's Avatar

Brandon Dickerson

28 Feb, 2020 07:32 PM

Hi, I have a Lenovo 100e Chromebook with a MediaTek MT8173C processor and I'm trying to install GeekBench 5. When I click on the "Get it from Google Play" download link, it opens up GeekBench 5 on the play store and I'm greeted to the message "Your device isn't compatible with this version". I've attached a screenshot of the error message. It doesn't give me a reason why, I'm running on the latest version of ChromeOS.

I also tried enabling Linux on the Chromebook and installing the Linux version, but I ran into trouble here as well. I followed the instructions here: http://support.primatelabs.com/kb/geekbench/installing-geekbench-5-on-linux but when I try running the Geekbench 5 installation, I get the error " Exec format error". I've attached a picture of this error as well.

Not really sure what to do from here, any help would be much appreciated. Thanks!

  1. 1 Posted by Brandon Dickers... on 04 Mar, 2020 11:00 PM

    Brandon Dickerson's Avatar

    I found the answer to my question. It's because my Chromebook uses ChromeOS in 32-bit mode, despite having a 64-bit capable processor. Here's an explanation of why. Geekbench 5 only runs on systems that have 64-bit processors and 64-bit Operating Systems.

    I still would like to know if Geekbench plans on supporting ARM64 for Linux. Because then I'd be able to install Geekbench through Linux on the Chromebook and run it from there.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screenshot_2020-02-28_at_2.22.16_PM.png 68.4 KB
  • Screenshot_2020-02-28_at_2.30.09_PM.png 37.4 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac