Geekbench 5.0.4 Metal benchmark might brick MBP 15" 2013

Tilo Probst's Avatar

Tilo Probst

24 Nov, 2019 11:05 PM

Hi Geekbench people,

here is something interesting.

I just tried to bench a MacBook Pro 15" 2013 (Intel HD 4400) with Geekbench 5.0.4. I did the CPU and OpenCL benches. The results were there, even though I don't see them in my account: https://browser.geekbench.com/user/162074 . Problem is the Metal benchmark. The bench pauses at "Horizontal [something]" with the timecode increasing, then it jumps to the next test, then back. Beechball when you try to leave Geekbench, no reaction on anything. The battery plug was not plugged in. In the menu bar the battery icon jumped between 5m+ and 12(?)m+. I tried to kill Geekbench with Alt-Cmd-Esc. Then the fans hearable kicked in. No other change. Then I shut the notebook down by holding the power button for a while.

Next, trying to turn on the notebook again, I can hear the fans spinning, the display back light is on, but no Apple logo, no boot up. It's just frozen.

That's the current status. Just letting you know that there might be a problem here. Have you ever seen anything like this? Have you tested this hardware config?

MBP 15" 2013, Intel HD 4400, Mac OS High Sierra 10.13.4, Geekbench 5.0.4

Best regards,
Tilo

  1. Support Staff 1 Posted by Colin on 25 Nov, 2019 08:45 PM

    Colin's Avatar

    Hi,

    Thank you for reaching out to us about this. This is a very unusual issue, and Geekbench should not be capable of impacting your device's ability to boot in any way. Primate Labs is not able to provide repair advice, but in a case like this where the system will not boot and no software diagnostics are possible we recommend taking your device to an Apple Store for inspection.

    Could you let me know which CPU your device has? According to our records, most MacBook Pro 15-inch 2013 systems have either the HD Graphics 4000 or the Intel Iris 5200 Pro, and I cannot locate the model that includes the Intel HD Graphics 4400.

    Also note that the minimum system requirements for Geekbench 5 include macOS 10.13.5 or later. This is unlikely to be related to this issue, but is notable if using Geekbench on other devices.

    All the best,
    Colin

    Primate Labs Inc.

  2. 2 Posted by Tilo Probst on 25 Nov, 2019 09:01 PM

    Tilo Probst's Avatar

    Hi,

    the notebook in question should be this one: https://everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-i7-2.0-15-iris-only-late-2013-retina-display-specs.html so you are right, that's not a HD4400 but an Iris Pro 5200. Also the installed Mac OS should be 10.13.6, not 10.13.4. The owner of the notebook says that since 2013 she has never seen any of the behavior I saw.

    The good news is that since then the notebook has booted back to life. Following what I described earlier I force-shutdown the notebook again. I then removed all external devices, including the external screen. Booting the notebook then was fine, albeit a longer bot than normal. On next boot I added all devices again.

    This time the boot took even longer. The progress bar was not even visible (only the Apple logo was there) and became visible only when it was maybe 90% done. Then the content of the 15" notebook screen snapped to the external 1440p monitor, but not in the same way it usually does. Instead of scaling to the larger physical size and being placed in the center, the content basically kept it's physical size and was aligned to the top left corner of the screen. Then the normal desktop kicked in. All boot attempts after that went normal.

    So yeah, looks to me like under circumstances the Geekbench Metal benchmark does "something" to the iGPU that Mac OS then corrects on succeeding boots. Since I don't know how in detail how the boot process works, where the Metal memory goes and how that relates to NVRAM or caches on the hard disc I can't really speculate.

    I guess the problem relevant to you is that GB hangs/loops under certain circumstances and makes the machine unusable.

    Just to keep you posted,
    Tilo

  3. Support Staff 3 Posted by Colin on 28 Nov, 2019 12:47 AM

    Colin's Avatar

    Hi,

    I see, thank you for the additional information. I'll pass this report along to my team and see if we can identify what could have caused an issue like this.

    If possible, would you be able to send me any files in the directory ~/Library/Logs/DiagnosticReports/ which have "geekbench" in the filename? If Geekbench crashed, it will have logged a report of it there, which would help us to investigate.

    All the best,
    Colin

    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac