GB5 Timer skew Ryzen Windows 10 no valid score

ajc9988's Avatar

ajc9988

03 Sep, 2019 07:08 PM

So, was going to buy this today, but there is no reason because I cannot resolve the HPET timer skew and without that I cannot get a valid score with it.

I have tried setting to multiple different timers. In fact, the error about the timer stopped popping up at all after I tried running benchmate 0.92. I then tried to run it from a standalone installation and the box didn't pop up.

So I was wanting some help to either figure out why I continue to get the timer error, even with spread spectrum disabled and HPET timer set in Windows 10, or I cannot purchase it.

I already was disappointed with GB4 weakening the Multi-core stressing in the way it did, making it worthless as a metric since it was lightly multi-threaded tasks mostly, but between GB3 and GB4, I stuck with it.

CPU = 1950X
MB = X399 Taichi

I still don't know how one person is completing the test on Asus boards in Win 10 Pro while I cannot get it to finish in Win 10 Ent.

  1. 1 Posted by ajc9988 on 03 Sep, 2019 08:29 PM

    ajc9988's Avatar

    So, I'm now getting a score with benchmate, but it does not upload a score to GB database, likely due to same error. It doesn't pop up a window, doesn't open the browser, and has no way for me to analyze the score on win 10.

    I set BCDedit to false, turned off HPET in BIOS, and a couple other things.

    Then there are comments on over-polling of the HPET here: https://community.hwbot.org/topic/191517-geekbench-5/?tab=comments#comment-538954

    Also, don't know if any of this was on your end, but a comment on what benchmate with GB5 was doing from that forum:

    " I've just encountered a strange synchronization bug on Ryzen with the new Geekbench 5 integration. As I've looked further I realized that instead of using the QueryPerformanceCounter() function about 2000 to 3000 times like in Geekbench 3 and 4, it's used about 14 million times during the same duration. I really don't know what to say other than that's incredibly stupid and obviously completely unnecessary. 

    So there is a contention bug currently showing only on AMD CPUs in BenchMate 0.9.1 + Geekbench 5. I've already fixed it and will upload an update in a few minutes or so. "

    But this just seems...

    Edit: Here is the link to my Win 7 GB5 submission, the ONLY score I could get for this CPU so far, which is NOT counted as it is on an unsupported version of Windows. Win 10 doesn't open a browser or upload the score for some reason using the trial version (meaning that the program, even when it does complete, is useless in trial mode because I cannot see the score without benchmate which captured the score at the end of the run).

    https://browser.geekbench.com/v5/cpu/20741

  2. Support Staff 2 Posted by John on 03 Sep, 2019 09:51 PM

    John's Avatar

    Interesting! We haven’t looked into HPET timer skew on AMD platforms. We’ll take a look and see if there’s anything we can do to fix the issue.

  3. 3 Posted by ajc9988 on 04 Sep, 2019 12:23 AM

    ajc9988's Avatar

    @John-

    Another update:
    Turns out the mods I have for my work desktop Win 10 Ent, or some software that I use on it, was the issue. Once I put it on my bench thumbdrive, no problems whatever on it.

    Considering I primarily use the bench drive to bench on, it is all good now. I just was honestly expecting GB5 to work on my work modded work desktop, but guess it is a different set of mods, slightly.

  4. Support Staff 4 Posted by John on 04 Sep, 2019 07:19 PM

    John's Avatar

    Which modifications do you have installed on your work desktop? We've a number of Threadripper systems in our lab and we've never encountered this sort of issue with any of them.

  5. 5 Posted by ajc9988 on 04 Sep, 2019 08:40 PM

    ajc9988's Avatar

    I create a custom ISO to start with, which doesn't effect my software and usage, but does break some of Microsoft's components in irreparable manners, necessitating a new build with updates integrated separately each time and removal of components after the upgrade integration. Some of these mods take place through NTLite, some through DISM from Windows ADK. I recently had other issues on the OS side where I had to make a new ISO to fix the desktop being broken on the system, which saved the deployment, but I have not had the time to either do a restore of the system from a clean backup image followed by installing with a clean upgrade ISO image, etc. After I backup the data on the system, then I can do that.

    But, it likely has to do with some of the settings I have in place related to usable browsers, as I did see something tried to switch my default browser from Firefox around the time I used your bench yesterday (and some of the mods I have made to the OS along with AV software and a couple other things make it so that getting access to other browsers can be difficult on that system, along with other settings preventing changes of default programs). So it likely was continuing trying to open through edge or internet explorer, which I have things in place to try to stop due to security, while not opening through Firefox. I believe that is where the primary issue was, which would be an oversight on my part (I'm used to using GB3 and 4 licensed versions, so it doesn't usually need a browser to popup at completion).

    As to the timer issue popup, that is likely a conflict on accessing polling data from the implementation of benchmate, potentially, as I have not seen it since version 0.9 of his program (.9.1 also had issues, but 0.9.2, put out within hours, did resolve it).

    In fact, I found out about the new GB version from the new version of benchmate coming out, rather than GB itself. But that is because benchmarking is a hobby of mine, not related to my work.

    It does work fine on my bench thumbdrive (Windows to go modified ISO that slims down a bit more than the LTSC Win 10 Ent.). As such, and because this seems better than GB4, although still not as good in multithreading as GB3 IMO, I will likely be buying the Win/Linux/Mac version this week.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac