Segmentation fault with compute benchmark on Ivy Bridge

ydrolet's Avatar

ydrolet

21 Jul, 2018 02:00 AM

When I run geekbench_x86_64 --compute OpenCL on my Linux machine, segmentation fault occurs when the face detection test begins. I run Geekbench 4.2.3 on Manjaro 64-bit kernel 4.14.54-1 with all latest updates. I have the package beignet v1.3.2-2 and llvm-libs v6.0.0-4. My CPU is an Intel Core i5 3317U with an integrated Intel HD Graphics 4000. Here is my Geekbench output after running the command:

Geekbench 4.2.3 Tryout : http://www.geekbench.com/

Geekbench 4 is in tryout mode.

Geekbench 4 requires an active Internet conn....
[...]

  Running Gathering system information
System Information
  Operating System              Manjaro Linux 4.14.54-1-MANJARO x86_64
  Model                         ASUSTeK COMPUTER INC. X202E
  Motherboard                   ASUSTeK COMPUTER INC. X202E
  Memory                        3.68 GB 
  BIOS                          American Megatrends Inc. X202E.210

Processor Information
  Name                                 Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
  Topology                      1 Processor, 2 Cores, 4 Threads
  Identifier                    GenuineIntel Family 6 Model 58 Stepping 9
  Base Frequency                2.60 GHz
  L1 Instruction Cache          32.0 KB x 2
  L1 Data Cache                 32.0 KB x 2
  L2 Cache                      256 KB x 2
  L3 Cache                      3.00 MB

OpenCL Information
  Platform Vendor               Intel
  Platform Name                 Intel Gen OCL Driver
  Device Vendor                 Intel
  Device Name                   Intel(R) HD Graphics IvyBridge M GT2
  Maximum Frequency             1.00 GHz
  Compute Units                 16
  Device Memory                 1.84 GB


OpenCL
  Running Sobel
  Running Histogram Equalization
  Running SFFT
  Running Gaussian Blur
  Running Face Detection
Segmentation fault (core dumped)

I noticed that the segfault is logged by dmesg. Here is what was logged in dmesg:

geekbench_x86_6[2079]: segfault at 7fff14c67fd8 ip 00007f889733d52a sp 00007fff14c67fe0 error 6 in libLLVM-6.0.so[7f8896996000+394a000]

Is there a workaround or could you fix it to be able to fully run the compute benchmark on my machine? The CPU benchmark fully runs without any issue.

Thanks!

  1. Support Staff 1 Posted by Sarah on 24 Jul, 2018 06:32 PM

    Sarah's Avatar

    Hi ydrolet,

    Thanks for bringing this to our attention. Unfortunately, we have no workarounds at the moment, but I have let the team know about this issue. I'll post here if I have any updates for you. In the meantime, let me know if there's anything else I can help with.

    All the best,

    Sarah
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac