No compatible compute devices found

isedhello's Avatar

isedhello

03 May, 2018 08:15 PM

Hi there, I'm trying to run the Compute Benchmark using Geekbench 4.2.2, but the "Run" button is greyed out and it says "No compatible compute devices found." Any workarounds? See screenshot and system details below. Thanks!

OS: Windows 10 Home version 1803
OS Build: 17134.1
Graphics: AMD Radeon Vega 8 Graphics
Graphics driver vers: 23.20.768.0

  1. Support Staff 1 Posted by Sarah on 04 May, 2018 03:16 PM

    Sarah's Avatar

    Hi isedhello,

    Thanks for posting about this. Have you tried running the Compute benchmark using the command line tool? What happens when you do so?

    If you haven't done this before, here is an article explaining how to do it (scroll down to 'Install the Tool on Windows'):
    http://support.primatelabs.com/kb/geekbench/geekbench-4-command-lin...

    Also, what do you get if you run the following command?:

    --compute-list
    

    Best,

    Sarah
    Primate Labs Inc.

  2. 2 Posted by isedhello on 04 May, 2018 05:57 PM

    isedhello's Avatar

    Hi, thanks for the response.

    When I run the --compute command, I get the following:

    [0504/134034:ERROR:consolemain.cpp(921)] Geekbench encountered an internal error and cannot continue. Please contact [email blocked] for assistance.
    
    Internal error message: clGetPlatformIDs.
    

    With --compute-list, there is no output beyond the program name, and the prompt returns after a short delay. When I view the --help list, there is a --cpu command listed (with runs OK), but not --compute or --compute-list.

  3. Support Staff 3 Posted by Sarah on 04 May, 2018 06:11 PM

    Sarah's Avatar

    Hi isedhello,

    That is interesting. Thanks for posting the error message as well. We will take a look at this as soon as possible. I'll let you know if I have an update.

    In the meantime, let me know if there is anything else I can help you with.

    Warm regards,

    Sarah
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Geekbench_Compute_-_no_compatible_devices.png 39.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac