GPU tests not working on Mac

david young's Avatar

david young

08 Mar, 2017 03:00 PM

hello just payed for and installed GB4 on a MacBook pro, GPU tests don't appear to be working please advise. CPU tests working fine thanks.

  1. 1 Posted by Ariella on 08 Mar, 2017 03:05 PM

    Ariella's Avatar

    Hi David,

    Could you please give me more information on your current situation? What sort of error messages are you receiving and what are the spec of your computer. The GPU test is located in the Compute tab on the left hand side of the program. Please try to run it with all other apps closed, and your device connected to power. If the problem persists, let me know and I will look into it further.

    Best,
    Ariella
    Primate Labs Inc.

  2. 2 Posted by david.j.young on 08 Mar, 2017 03:25 PM

    david.j.young's Avatar

    Hello Ariella,

     

    Thanks for the prompt and courteous reply. I’ve attached a screenshot of the GPU (Compute) image, on the windows version I can select the GPU to test, as well as the test type (OpenCL, CUDA). I am not given that option on the MAC. When I press the Run Compute Benchmark button the screen goes away and immediately returns.

     

    Here’s a link to the CPU tests which were successfully run. https://browser.geekbench.com/v4/cpu/2040421

     

    Please let me know if you need more information.

     

    Thanks again,

     

    David Young

  3. 3 Posted by Ariella on 08 Mar, 2017 04:20 PM

    Ariella's Avatar

    Hi David,

    Thanks for letting me know about this issue. I'm going to file this with our engineering team so they can take a look at it. My apologies for any inconvenience this is causing you! As soon as I have more information about this, I'll follow up with you. In the meantime, please try a system reboot. If it does start to work, please let me know.

    All the best,
    Ariella
    Primate Labs Inc.

  4. 4 Posted by david.j.young on 08 Mar, 2017 04:23 PM

    david.j.young's Avatar

    Hello Ariella,

     

    I tried the reboot, same results, thanks.

     

    David Young

  5. 5 Posted by timothycampanis on 22 Mar, 2017 07:37 PM

    timothycampanis's Avatar

    Hello I am having the exact same issue. Was a solution found?

  6. 6 Posted by matt on 30 Mar, 2017 03:39 AM

    matt's Avatar

    Also having the same issue here. The test seems to get through Sobel and then as soon as Histogram Equalization begins the test quits, but the application remains open.

  7. 7 Posted by rnsjunkmail on 30 Mar, 2017 05:13 AM

    rnsjunkmail's Avatar

    I can't run it either.... it doesn't allow me to select a Compute API or a Compute Device. At the bottom of the window it says...

    "No compatible compute devices found"

  8. 8 Posted by matt on 30 Mar, 2017 05:34 AM

    matt's Avatar

    In my case, I'm able to click the "Run Compute Benchmark" button, but the test fails shortly afterward.

  9. 9 Posted by timothycampanis on 30 Mar, 2017 07:10 AM

    timothycampanis's Avatar

    It is because of NVIDIA web drivers

    TAC

  10. 10 Posted by Andreas Michala... on 02 Apr, 2017 12:56 PM

    Andreas Michalak's Avatar

    Tried V 4.1. OS X El Capitan , Nvidia Web drivers (newest), CUDA drivers newest
    Same, only OpenCL compute rnns well (14000 Result)
    CUDA - click run does nothing, no error message, also nothing in the console log!!!
    Metal (new) - same as CUDA, run does nothing, no error messagealso nothing in the console log!!!
    Metal in generall works for me, no problems running some Metal benches.
    Same is for CUDA. no problems.
    I
    I think there should be some debug code added to figure out what goes wrong.

  11. 11 Posted by hoy thompson on 19 Aug, 2017 01:11 PM

    hoy thompson's Avatar

    testing a range of mac to compare, but not able to run graphics test on MBP5,5 with Nvidia 9400M (see attached screen shots) - other macs are being tested fine, so is this MBP just too old? It's not a big deal, just curious.

  12. Support Staff 12 Posted by Colin on 27 Sep, 2017 09:49 PM

    Colin's Avatar

    Hi,

    Thanks for your patience, and I apologize for the delayed response.

    Thanks for your report Hoy. Geekbench 4 supports Mac OS X 10.10.5 or later, and it should work fine on a MacBookPro5,5 running OS X 10.11.6. What kind of error are you experiencing? Does the benchmark start, and if so when does it stop?

    Andreas and rnsjunkmail, could you tell me what model you are running the benchmark on so that we can investigate further?

    Best,
    Colin
    Primate Labs Inc.

  13. 13 Posted by rnsjunkmail on 28 Sep, 2017 01:26 AM

    rnsjunkmail's Avatar

    It has been so long I am not sure which scenario it was.. I believe it may have been using the 2011 iMac i7 2.8GHz with 32 GB RAM running either El Capitan or Sierra

  14. Support Staff 14 Posted by Colin on 28 Sep, 2017 02:18 PM

    Colin's Avatar

    Hi,

    Thanks for the information! I will pass this along and investigate as soon as possible.

    Best,
    Colin
    Primate Labs Inc.

  15. 15 Posted by david.j.young on 30 Sep, 2017 04:42 PM

    david.j.young's Avatar

    Hello,

     

    Progress, thanks. After upgrading to macOS 10.12.6 (Build 16G29), and upgrading to the latest Geekbench, and using gfxCardStatus to use the discrete GPU (nvidia GeForce gt330m), got numbers for the OpenCL workload : https://browser.geekbench.com/v4/compute/1194970 . Still not able to select the workload, or the card to test. When using gfxCardStatus to enable the integrated (Intel) adapter the Compute test immediately returns without numbers as before. Here’s the CPU tests link https://browser.geekbench.com/v4/cpu/4286868. Thanks.

  16. 16 Posted by David Young on 30 Sep, 2017 06:48 PM

    David Young's Avatar

    Hello again, is it possible to build Geekbench with Xcode for debugging locally? thanks.

  17. Support Staff 17 Posted by Colin on 02 Oct, 2017 10:30 PM

    Colin's Avatar

    Hi David,

    By "workload", do you mean the API, or are you trying to run a Geekbench workload like Sobel in isolation? Geekbench workloads can only be run individually through the Geekbench 4 Pro command line interface.

    You mentioned previously the error that appears when you clicked the Run Compute Benchmark button. What kind of error are you currently encountering which is preventing you from choosing the details of your compute test?

    I'm afraid that we cannot provide a debug version of Geekbench.

    Best,
    Colin
    Primate Labs Inc.

  18. 18 Posted by david.j.young on 03 Oct, 2017 01:29 AM

    david.j.young's Avatar

    Hello Colin,

     

    1) Yes I mean the API.

    2) No error or results are returned when the integrated (Intel) adapter is enabled by gfxCardStatus. The application immediately returns, no errors or results.

     

    Thanks. Not a big issue just curious.

  19. 19 Posted by rugambaimable on 06 Oct, 2017 06:46 PM

    rugambaimable's Avatar

    how to change internet network

  20. Support Staff 20 Posted by Colin on 06 Oct, 2017 07:11 PM

    Colin's Avatar

    Hi rugambaimable,

    Could you go into a bit more detail about what you're looking for so that I can help you out?

    Best,
    Colin
    Primate Labs Inc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac