Geekbench 4 Compute tests CUDA / OpenCL showing zero score on MacBookPro11,3 under Windows 10 Pro

james.loader's Avatar


19 Dec, 2016 10:55 PM

Hi there

I am running into a strange issue with Geekbench 4 Compute tests running on a MacBookPro11,3 (mid-2014 Retina MacBook Pro 15") under Windows 10 Pro x64 for both Iris Pro and GT750M chipsets.

The CUDA / OpenCL tests seem to run, but then show a zero score in the results browser.

e.g. and

Has anyone else run into this please?


Showing page 2 out of 3. View the first page

  1. 31 Posted by Mean Machine on 19 Jun, 2017 05:06 PM

    Mean Machine's Avatar

    Same issue here.
    zBook17 G1, 4930MX with K5100m running win10/nVidia 377.35

  2. 32 Posted by Al Quz Mar on 07 Aug, 2017 09:36 AM

    Al Quz Mar's Avatar

    Can anyone recommend an alternative software that does more or less the same thing but actually works?

  3. 33 Posted by akshat on 27 Sep, 2017 10:19 AM

    akshat's Avatar

    Same here on MacBook Air 2017

  4. Support Staff 34 Posted by John on 27 Sep, 2017 08:07 PM

    John's Avatar

    Thank you for your patience. We have determined that the problem is a result of a bug in older NVIDIA drivers. Please download the latest version of the NVIDIA drivers and the Geekbench Compute Benchmark should work as expected on your NVIDIA GPU.

    You can get the latest version of the NVIDIA drivers from the following page:


  5. 35 Posted by kipbeatty on 02 Oct, 2017 12:40 PM

    kipbeatty's Avatar


    You can't be seeing the same on a MacBook Air as the MacBook Air doesn't use an NVIDIA GPU and won't run the CUDA benchmark.

    FWIW, the 2017 MacBook Air has Intel HD Graphics 6000 as the GPU.

  6. 36 Posted by kipbeatty on 02 Oct, 2017 01:38 PM

    kipbeatty's Avatar


    The problem with your "solution" is that the issue is worse with the latest NVIDIA drivers on Mac, not better. Running High Sierra, I now also get a "0" score when testing the discrete NVIDIA GPU in the OpenCL test. Previously, I would get a score. It's no longer limited to CUDA tests.

  7. 37 Posted by Colin on 02 Oct, 2017 10:19 PM

    Colin's Avatar

    Hi kipbeatty,

    I'm sorry to hear that the issue is persisting. I'm investigating the issue on our end now and will let you know if I can provide any updates or solutions. Thanks for your patience.

    Primate Labs Inc.

  8. 38 Posted by Flavio on 11 Oct, 2017 06:14 PM

    Flavio's Avatar

    Hi there! Any news about this problem?

    I have a MacBookPro10,1 GeForce GT 650M and macOS 10.13 (High Sierra) and I always have score 0 when analysing Depth of Field...


  9. 39 Posted by shorebreeze on 03 Dec, 2017 05:56 PM

    shorebreeze's Avatar

    Also getting a score of zero. Nvidia 750, late 2013 Retina MacBook Pro, High Sierra with the latest updates and security patch, 2.3GHz i7 with 16GB RAM.

  10. Support Staff 40 Posted by John on 03 Dec, 2017 06:27 PM

    John's Avatar

    We’re aware of the issue on High Sierra with GeForce GT 750M and have determined it is due to the drivers that ship with 10.13. We have notified Apple and are waiting for them to release an update to macOS that resolves the issue.

  11. 41 Posted by Danial on 07 Dec, 2017 08:54 PM

    Danial's Avatar

    Same problem with a GTX 675MX with high sierra

  12. 42 Posted by Colin on 07 Dec, 2017 10:54 PM

    Colin's Avatar

    Hi Danial,

    Thanks for letting us know about about this, and I'm sorry for any trouble caused by this issue. Could you let me know which version of High Sierra your system is on (e.g. 10.13.0, 10.13.1) and what version of Geekbench you have (e.g. 4.1.4, 4.2.0)?

    All the best,
    Primate Labs Inc.

  13. 43 Posted by Daniel Bliss on 08 Dec, 2017 01:51 AM

    Daniel Bliss's Avatar

    High Sierra 10.13.1, and Geekbench 4.2

    Haven’t yet run it on 13.2

  14. 44 Posted by Colin on 08 Dec, 2017 03:05 PM

    Colin's Avatar

    Thanks Daniel. Pardon the additional questions, but could you also let me know if you're running the Compute benchmark with OpenCL or with CUDA, and whether you're using the macOS driver or the NVIDIA web driver? This would help us narrow down the scope of the issue and potentially the cause of it.

    Primate Labs Inc.

  15. 45 Posted by Daniel Bliss on 08 Dec, 2017 03:08 PM

    Daniel Bliss's Avatar

    I ran it with Open CL; this is with the free version of Geekbench.

  16. 46 Posted by Colin on 08 Dec, 2017 03:23 PM

    Colin's Avatar

    Thanks again Daniel. I'll get back to you as soon as I can if I can provide more information.

    All the best,
    Primate Labs Inc.

  17. 47 Posted by kipbeatty on 09 Dec, 2017 05:25 PM

    kipbeatty's Avatar


    I'm going to jump in here on the macOS High Sierra issues as I think I can help. First, like others, since High Sierra I have been getting a 0 score when trying to run compute tests with the NVIDIA GeForce GT 750M in my mid-2014 MacBook Pro.

    In addition to this issue, I've been unable to run the CUDA tests at all because the NVIDIA CUDA Mac driver is no longer compatible with the latest version of High Sierra, 10.13.2 (and .1 FWIW). So, I did some digging.

    I discovered that the built in NVIDIA drivers included with the latest macOS update are NOT the latest version available for the Mac. As not to take credit for someone else's work, I'm going to include the link to the page I found which details how to download, and install, the more recent NVIDIA drivers on select Macs and MacBook Pros. It's beta, and it's not available for all Macs, so install at your own risk. All I can tell you is they've worked very well for me.

    Having installed the update, I can report the following:

    1. CUDA now works. It works again with the apps that utilize it (Digital Photo Professional, for example), and it tests well in Geekbench again (18,298 FWIW).

    2. The OpenCL and Metal tests, utilizing the GT 750M, run well in Geekbench again.

    3. Finally, and this is by far the most important as far as I'm concerned. Using the updated NVIDIA drivers, I'm seeing a significant boost in Metal and OpenCL performance according to Geekbench (CUDA is relatively unchanged). I would perhaps have chalked it up to Metal 2 or other factors with the macOS updates, but I did not see any such performance gains prior to the NVIDIA driver update, or with the integrated Intel Iris Pro.


    Before Update: 16945
    After Update: 21540


    Before Update*: 13750
    After Update: 15826

    *Last time I could run it and not get a "0" score before updating the NVIDIA drivers was under 10.12 (macOS Sierra).

    I hope this is of some help to the guys at Primate Labs and the users.

  18. 48 Posted by Paul on 10 Dec, 2017 07:48 PM

    Paul's Avatar

    I'm having the same issue for the GeForce GT 650M
    The graphic processes are running really slow since I've upgraded to high Sierra 10.13.1 (17B1003)
    Just to make sure I got this correct: my NVIDIA GeForce GT 650M 1 GB drivers aren't correct? Is there something I need to do to get the GPU accelerator back running?
    Thank you

  19. 49 Posted by Paul on 10 Dec, 2017 08:36 PM

    Paul's Avatar

    GPU: GeForce GT 650M
    OSX: high Sierra 10.13.1 (17B1003)

    I installed the first driver here: and it apparently my graphic activities run smoother.

  20. 50 Posted by Daniel Bliss on 11 Dec, 2017 04:15 AM

    Daniel Bliss's Avatar

    Not quite sure if this was intended for me or someone else.

    I have, however, had inconsistent graphic performance since upgrading to High Sierra; sometimes the computer feels a bit sluggish and there are often problems with coming out of sleep when connected to an external monitor.

  21. 51 Posted by Colin on 11 Dec, 2017 05:42 PM

    Colin's Avatar

    Hi Paul,

    Thanks for letting us know about the issue on your device, and I'm sorry for any trouble that it caused. It's possible that installing other drivers may resolve this issue, though we recommend caution as always when installing drivers from other parties.

    I'll pass along your report for the GeForce GT 650M and let you know as soon as I can if we can provide more information about this issue.

    All the best,
    Primate Labs Inc.

  22. 52 Posted by Paul on 12 Dec, 2017 04:22 PM

    Paul's Avatar

    Hey friends,

    Just so ya'll know my accelerator works better but still gives abnormalities on the screen.
    I mean it feels like something is not right. Anyways I believe it's not the case for reballing.
    I'm a bit confused about the OSX release and the staff that tested it ...
    GPU: GeForce GT 650M
    OSX: high Sierra 10.13.1 (17B1003)

    This is a short video of the screen doing it:

  23. 53 Posted by Conny on 29 Dec, 2017 09:52 PM

    Conny's Avatar

    I have the same issue with - GeForce GTX 775M - can anyone help me out?

  24. 54 Posted by Colin on 05 Jan, 2018 09:24 PM

    Colin's Avatar

    Hi Conny,

    Thanks for reaching out to us about this, and I'm sorry for the delayed response. Could you link me to your result in the Geekbench Browser?

    All the best,
    Primate Labs Inc.

  25. 55 Posted by Cornelia Benisc... on 05 Jan, 2018 11:03 PM

    Cornelia Benischek's Avatar

    Hi Colin,
    thanks for the reply, the link is - <>
    I solved the problem now by installing the nvidia app and use the web driver - now it works - I guess all the nvidia cards on macs with sierra and high sierra os have the same problem with the os driver delivered from apple… rendering video with the os delivered driver was really a problem - with geekbench browser I was able to figure out the problem - before I had no clue why my mac shuts down when rendering video.

    All the best

  26. 56 Posted by Axel on 23 Mar, 2018 04:37 PM

    Axel's Avatar

    Exactly same problem on MacBook mid-2014 with Nvidia GeForce GT 750M card, under Mac OS X.
    Using the Intel Iris Pro GPU I get proper results, so it is not a platform issue, but something more lower level, like with OpenCL.

  27. 57 Posted by brdeveloper on 15 Nov, 2018 07:23 PM

    brdeveloper's Avatar

    The issue is still present on Geekbench 4.3.1 as shown in the attached picture.

  28. Support Staff 58 Posted by John on 16 Nov, 2018 04:23 AM

    John's Avatar

    This is due to a known issue with the GeForce 750M drives included with macOS. We've notified Apple and the response we received indicated that Apple has no plans to fix the issue.

  29. 59 Posted by Tamas on 03 Mar, 2019 09:45 AM

    Tamas's Avatar

    Strangely I can't even get my 750M show up in Photoscan to use as a GPU ... Does the 750m work at all in this case (I mean in OSX in general) ?

  30. 60 Posted by Paul Ionut ANTO... on 05 Mar, 2019 09:29 AM

    Paul Ionut ANTONESCU's Avatar

    There are no drivers in the latest xos version. I simply downgrade the OS
    10.12.6 - the last know Apple OS to include the GeForce 750M drivers
    IMO this is Apple's approach in order to make you buy a new product.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac