4.0 doesn't work on yosemite

kris's Avatar

kris

31 Aug, 2016 11:09 AM

High,

The application gives the following error on launch.

Process: Geekbench 4 [1499]
Path: /Applications/Geekbench 4.app/Contents/MacOS/Geekbench 4
Identifier: com.primatelabs.Geekbench4
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Geekbench 4 [1499]
User ID: 501

Date/Time: 2016-08-31 13:08:11.855 +0200
OS Version: Mac OS X 10.10.5 (14F1909)
Report Version: 11
Anonymous UUID: 390EF4A5-F033-FEA9-3037-5A80C17E56E9

Time Awake Since Boot: 3400 seconds

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/Metal.framework/Versions/A/Metal
  Referenced from: /Applications/Geekbench 4.app/Contents/MacOS/Geekbench 4
  Reason: image not found

Binary Images:
    0x7fff6b23d000 - 0x7fff6b27392f dyld (353.2.4) <708E385E-50C6-32A3-983C-42E97BEE4346> /usr/lib/dyld
    0x7fff93b3c000 - 0x7fff93cecff3 com.apple.QuartzCore (1.10 - 361.19) <E59000AA-DC30-3F73-A103-0240576C9556> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

  1. 1 Posted by tocophonic on 31 Aug, 2016 12:06 PM

    tocophonic's Avatar

    Hi Kris,
    it's most likely not working because the minimum requirement to run Geekbench 4 on Mac is 10.11.4 (El Capitan)

  2. 2 Posted by Kris Gorski on 31 Aug, 2016 01:40 PM

    Kris Gorski's Avatar

    Ok. Thanks :-)

  3. 3 Posted by René Troost on 31 Aug, 2016 07:12 PM

    René Troost's Avatar

    Hi tocophonic

    Sad to hear that and did not expected that it would not run on Yosemite.
    Any change in the future they will make it run on Yosemite?

    Thanks

  4. Support Staff 4 Posted by John on 31 Aug, 2016 09:35 PM

    John's Avatar

    Geekbench 4 requires 10.11 or later (and will not work on 10.10 or earlier). We'll work to make this requirement clearer in future updates.

    We do not have any plans to support 10.10 as the Compute Benchmarks require the updated GPU drivers that ship with 10.11.

  5. 5 Posted by tocophonic on 31 Aug, 2016 10:55 PM

    tocophonic's Avatar

    John,
    why not just disable the Compute Benchmark for <10.11 Users? This way these people would at least be able to do the standard CPU Benchmarks. Just as an input ;-)

  6. Support Staff 6 Posted by John on 05 Sep, 2016 05:47 AM

    John's Avatar

    It's unfortunately a non-trivial effort to support both 10.10 and Compute Benchmarks in the same executable.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac